How to download Xcode DMG or XIP file? – Dev

The best answers to the question “How to download Xcode DMG or XIP file?” in the category Dev.

QUESTION:

Where does the Mac App Store download the files to under Lion? I need the DMG file in order to repair something in my system, but how can I access that file?

ANSWER:

You can find the DMGs or XIPs for Xcode and other development tools on https://developer.apple.com/download/more/ (requires Apple ID to login).

You must login to have a valid session before downloading anything below.

*(Newest on top. For each minor version (6.3, 5.1, etc.) only the latest revision is kept in the list.)

Xcode 13

  • 13.2

  • 13.1

  • 13.0

Xcode 12

  • 12.5.1 (requires a Mac with Apple silicon running macOS Big Sur 11 or later, or an Intel-based Mac running macOS Big Sur 11 or later) (Latest as of 22-Jun-2021)

  • 12.4 (requires a Mac with Apple silicon running macOS Big Sur 11 or later, or an Intel-based Mac running macOS Catalina 10.15.4 or later)

  • 12.3 (requires a Mac with Apple silicon running macOS Big Sur 11 or later, or an Intel-based Mac running macOS Catalina 10.15.4 or later)

  • 12.2

  • 12.1

  • 12.0.1 (Requires macOS 10.15.4 or later) (Latest as of 24-Sept-2020)

Xcode 11

  • 11.7 (Latest as of Sept 02 2020)

  • 11.6

  • 11.5

  • 11.4.1 (Requires macOS 10.15.2 or later)

  • 11.3.1

  • 11.2.1

  • 11.1

  • 11 (Requires macOS 10.14.4 or later)

Xcode 10 (unsupported for iTunes Connect)

  • 10.3 (Requires macOS 10.14.3 or later)
  • 10.2.1 (Requires macOS 10.14.3 or later)
  • 10.1 (Last version supporting macOS 10.13.6 High Sierra)
  • 10 (Subsequent versions were unsupported for iTunes Connect from March 2019)

Xcode 9

  • 9.4.1
  • 9.3.1
  • 9.2 (Last version supporting macOS 10.12.6 Sierra)
  • 9.1
  • 9.0.1

Xcode 8

  • 8.3.3
  • 8.2.1 (Last version supporting OS X 10.11.5 El Capitan)
  • 8.1
  • 8.0

Xcode 7

  • 7.3.1
  • 7.2.1 (Last version supporting OS X 10.10 Yosemite)
  • 7.1.1
  • 7.0.1

Xcode 6

  • 6.4
  • 6.3.2
  • 6.2 (Last version supporting OS X 10.9.5 Mavericks)
  • 6.1.1
  • 6.0.1

Even Older Versions (unsupported for iTunes Connect)

  • 5.1.1 (Latest version supporting OS X 10.8 Mountain Lion)
  • 5.0.2
  • 4.6.3
  • 4.5.2
  • 4.4.1
  • 4.3.2
  • 4.2
  • 4.1
  • 4.0.2
  • 3.2.6
  • 3.1.4
  • 3.0
  • 2.5
  • 2.4.1
  • 2.3
  • 2.2.1
  • 1.5
  • 1.0